跳到主要内容

RcloneView 1.6 – 发行说明

发布日期: 2026 年 10 月
支持平台: Windows、macOS、Linux

RcloneView 1.6 是一个以正确性为重点的版本。两种会导致文件丢失的情形和一个对网络开放的端口已被堵上;您在作业中输入的标志现在会真正发送给 rclone;失败的同步不再把自己报告为已完成;RcloneView 也不再关闭不属于它的 rclone 进程。1.6 的后续更新还会阻止密码错误的远程反复登录、直到服务器封锁这台计算机,并阻止计划作业在每个打开的窗口中各运行一次。此外,本版本还修复了挂载、文件浏览器、远程创建、向导以及三个平台上的打包等方面的大量问题。

升级前请务必阅读​

  • 作业“自定义标志”中的过滤标志现已生效。 在作业的 自定义标志 框中输入的 --include、--exclude、--filter 等过滤标志,过去在作业运行前就被丢弃了——它们只在试运行和 bisync 诊断时才生效,因此预览与实际运行可能不一致。现在所有路径都会传递这些标志。
    这会改变现有作业的行为。 如果您有在自定义标志中使用过滤标志的作业,它现在只会传输匹配的文件,而不是全部文件。对于启用了删除的 同步 作业, 这也会改变目标位置上被删除的内容。请检查所有在自定义标志中保留过滤标志的作业,并在让它按计划运行之前,先用 试运行 运行一次。

  • 密码为长令牌的远程需要重新输入一次密码。 保存远程时,RcloneView 过去让 rclone 自行判断收到的密码是否还需要编码。对于看起来像 base64 的密码,这个判断总是错的, 因此该值被未经编码就写入了配置,随后在每次连接尝试时又被打乱。以这种方式保存的远程从未能够通过认证。RcloneView 现在会自行对密码编码, 因此从此版本起,您添加或编辑的任何内容都会被正确存储。
    已经以这种方式保存的远程不会被此次更新修复。 这只影响长度为 22 个字符或以上、且完全由字母、数字、- 和 _ 组成的密码—— 实际上就是 API 令牌或生成的应用专用密码,而不是您自己选择的密码。如果您有一个一直因认证错误而无法连接的远程,请在 远程管理器 → 编辑 中打开它,重新输入密码并保存。此后它就能连接了。
    不要重新输入目前能够正常打开的 Crypt 远程的密码。 以这种方式保存的 Crypt 远程从未出现过故障:它的文件是用被打乱后的值加密的, 只有该值才能把它们读回来。现在输入真正的密码会让该远程切换到另一把密钥,里面已有的文件将无法再打开。请保持这类远程不变—— 编辑它的其他设置是安全的。如果您已经重新输入了密码、文件随之无法打开,请把旧值放回 rclone.conf:它就是密码本身,只是未经编码写入。 若要让这样的远程改用真正的密码,请先通过现有的远程把文件复制出来,然后重新创建该远程。

  • 启用应用锁后,解锁之前不会启动任何内容。 锁定屏幕现在会在任何窗口内容之前出现,rclone、计划作业、自动挂载和 Web 服务器都会等待输入密码,而不是在锁定屏幕背后启动。 如果启用了应用锁的 RcloneView 在登录时自动启动,则在有人解锁之前,计划作业和自动挂载不会运行。如果这台计算机依赖作业或挂载在重启后无人值守地运行, 请关闭应用锁,或在每次登录后解锁应用。

  • 登录被拒绝的远程不再被自动连接。 对于使用密码登录的远程——SFTP、FTP、WebDAV 和 SMB——RcloneView 现在会检查一次登录,如果服务器拒绝, 就停止连接该远程:不再自动挂载,不再运行计划作业,也不再重新打开它的标签页。这一状态在重启后依然保留。使用此类远程的计划作业会被记录为失败, 并发送通常的失败通知。当您在文件浏览器中点击 重试,或在 编辑远程 中保存了更正后的密码后,才会恢复连接。
    如果服务器只是暂时拒绝登录——例如正在更改密码期间——该远程上的计划作业之后会一直保持暂停,直到有人点击 重试。 通过浏览器或密钥登录的云存储不受影响。

  • 计划作业现在只从主窗口运行。 计划跟随主窗口的 rclone 连接。如果您只把次要窗口切换到了另一个连接,那么在该窗口打开期间,该连接的计划作业将不再运行;请改为在主窗口中选择该连接。 如果主窗口意外关闭,计划作业会停止,直到重新启动 RcloneView,即使其他窗口仍然打开也是如此。

数据丢失与安全​

  • 部分删除失败后重试可能清除父文件夹: 一次删除多个文件、其中一些失败,然后点击 重试,可能会删除整个父文件夹,而不是重试失败的文件。现在重试只作用于失败的项目。

  • 名称中含有 [ ] * ? { 的文件可能导致误删其他文件: 删除多个文件时,它们的路径在未转义的情况下被交给了 rclone 的过滤引擎,因此包含模式字符的名称会被当作通配符处理。一次单独的删除可能匹配并删除其他文件夹中的文件。 现在路径在用作过滤条件之前会先转义。

  • 用已有名称创建远程会替换该远程: rclone 把“创建”视为“创建或更新”,因此用一个已被占用的名称创建远程——即使存储类型不同——也会悄悄覆盖现有远程的设置和凭据。 现在,当您输入已被占用的名称时,“新建远程”对话框、向导以及向导的 Crypt 步骤会立即发出警告,且不会继续。

  • 窗口之间使用的端口对网络开放: RcloneView 用于自身窗口之间通信的端口(13542)过去监听所有网络接口,而不只是本机,并且主窗口接受空的认证密钥。 现在它只绑定到本机,并且要求使用真正的密钥。

亮点功能​

  • RcloneView 不再停止您的其他 rclone 进程: 退出应用、重启 rclone 或运行 更新 Rclone 时,过去是按名称终止 rclone,这也会杀死这台机器上的其他所有 rclone—— 您在终端中启动的 rclone mount、cron 作业,或其他使用 rclone 的工具。现在 RcloneView 只会停止它自己启动的进程。

  • 密码错误不再导致这台计算机被封锁: 一个密码错误的 SFTP 远程可能会登录几十次,直到 NAS 封锁这台计算机的 IP 地址。rclone 对被拒绝的登录每个请求最多重试十次,打开一个标签页会同时发出多个请求, 而应用还会在列表失败后再重试三次——一个标签页大约会产生 80 次登录。应用还会在启动时、恢复标签页时、自动挂载时以及运行计划作业时自行发起连接。 对于使用密码登录的远程(SFTP、FTP、WebDAV、SMB),RcloneView 现在会检查一次登录,一旦被拒绝就停止。文件浏览器会显示 登录失败, 并带有 编辑远程 和 重试 按钮——对于 Crypt 或 alias 远程,它会指向其底层的远程——远程管理器会显示 登录失败 徽章,而不是可用空间。 在 新建远程 中用错误密码添加的远程不会被保存。当服务器在反复失败后停止响应时,文件浏览器现在会在几秒内提示 IP 可能已被封锁,而不是转圈约 50 秒。

  • 计划作业在每个打开的窗口中各运行一次: 每个 RcloneView 窗口过去都运行自己的调度器,因此在打开第二个窗口时,每个计划作业和批处理都会在同一时刻按窗口各启动一次。两个副本写入同一个本地文件夹时会互相删除对方的部分文件, 运行最终可能什么也没有复制。在次要窗口中更改或删除计划,还会让主窗口继续触发旧的计划。现在计划只从主窗口运行,其他窗口中所做的更改会传递给它。 在计划触发的瞬间点击 运行,或连续快速点击两次,同样可能把同一个作业启动两次;现在只会启动一次。

  • 升级前的 rclone 仍在继续运行: 升级 RcloneView 后,上一个版本遗留的 rclone 会被继续使用,因此在手动停止该进程之前,新捆绑的 rclone 不会被使用。现在,当运行中的版本不同时,RcloneView 会重启 rclone。 它也不再把恰好使用 rclone 端口的其他程序误认为 rclone——这曾导致应用只显示 无连接——而是改在下一个空闲端口上启动 rclone。在退出或重启 rclone 时, 应用现在会等待 rclone 自行关闭;过去它每次都强制杀死 rclone,而这发生在挂载被卸载、VFS 缓存被清理之前。

  • 自定义标志和全局标志现在真正生效: 您配置的标志过去会以多种不同的方式被悄悄丢弃,这就是为什么在命令行中有效的标志在应用中看起来毫无作用。本版本修复了以下问题:设置中的全局 rclone 标志没有应用到同步/复制作业; 放入作业自定义标志中的后端标志和进程级标志被忽略;批处理步骤字段(带宽限制、包含、最小/最大时间、最小/最大大小)以 rclone 会丢弃的形式发送;用数字书写的布尔标志(--checksum=1,在命令行中有效) 会让整个请求失败,导致作业根本无法启动;重复的 --backup-dir 和 --compare-dest 标志被拒绝;--header、--header-upload、 --header-download 和 --compare-dest 被转换成了错误的类型;标志解析器无法处理值内部的引号或空格;试运行完全不包含自定义标志,因此预览与实际运行不一致; 全局标志框中的一个错误字符会悄悄丢弃所有标志,而不只是出错的那一个。

  • 失败的同步不再报告“无变更”: 在传输任何内容之前就失败的同步——凭据错误、远程无法访问、路径缺失——过去会在作业列表、历史记录和通知中显示为没有变更的已完成运行。现在会读取 rclone 为该作业报告的错误, 因此失败会被显示为失败。

  • 列表失败不再被当作空文件夹: 当文件夹无法列出时,应用的多个部分过去会认为它只是空的。正因如此,挂载可能被放在已有内容之上,挂载的 验证 总是通过,文件夹树、比较和路径选择器对于一个装满文件的文件夹也可能什么都不显示。 现在列表失败会被报告为失败——列表视图也会如此显示,而不是看起来像一个空文件夹。

  • 中途放弃的登录阻塞了所有新远程: 未完成就关闭服务商的登录页面,会让 rclone 的授权助手一直占用端口 53682,之后每一次通过浏览器登录来创建远程的尝试都会失败。重启应用也无法释放它—— 唯一的办法是强制退出 rclone。现在,当登录被放弃时,该助手会被关闭。

新增功能与改进​

  • 按作业设置上传并发数: 后端上传并发数(upload_concurrency)现在可以在单个作业上设置,而不只是全局设置,因此针对高速远程的作业不必再与其他所有作业共用同一个设置。

  • 新建的远程直接在面板中打开: 创建远程之后,它现在会立即在文件浏览器面板中打开,而不必由您自己去查找并打开。

  • 文件浏览器中显示可用空间: 对于能够报告剩余空间的远程,文件浏览器现在会显示该远程的剩余空间。

  • 更快地从比较视图复制: 从比较视图复制时,过去每个项目启动一个 rclone 作业,并且无论 --transfers 设置为多少,都只同时运行四个。现在项目会按远程和父文件夹分组,合并为一次同步/复制, 并且会遵循您的 --transfers 设置。

  • “配置文件已更改”弹窗不再打断操作: rclone 配置文件在磁盘上发生更改的通知,不再在您操作到一半时占据整个屏幕。

  • 严格代理环境下的许可证注册: 一些大学和企业的代理会阻止用于注册许可证的请求方法。现在,当第一种方法被拒绝时,注册和注销会回退到第二种方法。

  • 缩小全局标志回退的范围: 过去当某个全局标志无法应用时,应用会丢弃整组标志——连 --bwlimit 这样原本有效的标志也一并丢弃。现在只会丢弃引起问题的那个标志。

  • Google Photos 指引: Google Photos 只会列出由此应用上传的照片,这是 Google 施加的限制——现在应用中会对此加以说明,而不是看起来像一个空账户。当无法建立连接时, 应用还会引导您创建自己的 OAuth 客户端 ID。

  • 更清晰的自定义标志警告: 自定义标志中针对 timeout、contimeout 和 user-agent 显示的警告文字已得到更正。

  • 选择挂载点: 向导现在会在您输入或浏览到挂载点时立即检查它,在无法使用时显示原因,并保持 下一步 为禁用状态——而不是在最后一步才失败,并在挂载管理器中留下一条失败的条目。 它只会建议确实可以创建的位置,首选 ~/Mounts/<remote>;当连接到另一台机器上的 rclone 时,它会建议该机器主目录下的文件夹。浏览 会在您选择的文件夹内添加一个以远程命名的文件夹, 而 使用其中的新文件夹 可以修正无法按原样使用的文件夹——在 Windows 上挂载文件夹必须尚不存在,在 macOS 和 Linux 上则必须为空。挂载管理器在保存前会检查相同的规则, 包括在 Windows 上检查您的账户无法在其中创建文件夹的父文件夹,并且会显示挂载失败的原因,而不是只显示 挂载失败。

  • 向导中的交互式演示: 向导欢迎屏幕上的每个任务都有一个 演示 链接,可在浏览器中打开该任务的交互式演练,全部演示 则列出所有演示。

  • iCloud Photos: 首次同步期间现在会显示照片总数,因此较长的首次运行不再看起来像是卡住了,并且双击缩略图可以在预览中将其打开。

问题修复​

作业、批处理与传输​

  • 在 S3 上重命名文件夹会留下旧文件夹: 批处理中的重命名和移动步骤会移动内容,却把原来的文件夹标记留在原处,因此旧文件夹仍会出现在文件浏览器中。在对象存储上,文件夹是一个标记对象,而批处理步骤既没有在目标位置创建标记,也没有删除源位置的标记。 作业管理器中的重命名也有同样的缺陷,并且还会在移动的同时运行对旧文件夹的清理,两者因此产生竞争;空文件夹最终甚至不会创建任何新文件夹。现在两者都会按顺序创建目标标记并删除源标记。

  • 在 S3 和 Swift 上重试重命名: 重试文件夹重命名会为原文件夹留下一个空标记。

  • 重试可能运行另一个作业: rclone 重启后,恢复的行与当前作业可能共用同一个作业 id,因此点击 重试 会重新运行错误的作业。

  • 多项目批量传输的重试总是失败: 涵盖多个项目的批量传输上的重试按钮从未成功过。

  • S3 上忽略多线程传输数量: 多线程传输数量 的值对 S3 目标没有任何作用,起作用的是后端自身的上传并发数。

  • 向导创建的作业名称重复: 向导只根据路径生成作业名称,因此两个作业可能得到相同的名称——进而在您编辑其中任何一个时阻止保存。

  • 试运行预览使用的选项与实际运行不同: 作业、批处理或向导的试运行会忽略 全局 Rclone 参数,并始终使用 --transfers=4 --checkers=8 进行检查,因此为了减轻繁忙服务器的负担而调低的检查器数量不会应用到预览。 批处理复制步骤的预览遗漏了该步骤的选项,过滤标志之外的自定义标志(例如 --fast-list 和 --compare-dest)在所有预览中都缺失,并且 --checksum 的传递方式与实际运行不同。

  • Crypt 上传一直停留在“运行中”且超过 100%: rclone 按加密后的字节数统计 Crypt 上传,这比文件本身的大小略多。已完成的 Crypt 上传的文件行在传输列表和历史记录中一直停留在 运行中,并且在运行时显示 183% 之类的数字。

  • 同步通知打开了另一次运行的详情: rclone 每次启动时都会从 1 重新给作业编号,因此点击完成通知时,可能显示复用了同一编号的另一次运行的源、目标和错误。

  • 已删除的计划批处理仍在运行: 在作业管理器中删除的计划批处理,在应用重启之前仍会按计划运行。另外还修复了:一个设置已损坏的作业会让连接管理器无法切换连接;在重新加载计划期间所做的计划更改被丢弃;快速连续点击两次 删除 可能会关闭作业管理器。

挂载​

  • 从远程 rclone 连接挂载: 当连接到另一台机器上的 rclone 时,应用仍然在本机上检查并创建挂载点,因此从 Mac 或 Linux PC 挂载总是失败。

  • 速度慢的驱动器被报告为“父文件夹不存在”(Windows): 创建父文件夹与探测驱动器所用的超时绑定在一起,因此速度慢的驱动器被误判为不存在。

  • rclone 端口变化后已保存的挂载消失: 内嵌的 rclone 在另一个端口上启动后,您已保存的挂载从列表中消失了。

  • 一段时间后出现“Too Many Open Files”: 在某些路径上,来自 rclone 的响应没有被完整读取,每次都会泄漏一个文件描述符,直到挂载完全无法工作。

  • SFTP 挂载的是主目录而不是服务器根目录: 路径规范化去掉了挂载目标开头的斜杠,因此对服务器根目录的挂载最终落在了账户的主目录上。

  • 挂载列表中的本地驱动器名称: 修复了本地驱动器名称的显示方式。

  • 已挂载的远程被列为“已配置”: 在 Windows 上,以及连接到另一台机器上的 rclone 时,已挂载的 alias 远程、有名称的本地远程,或指向盘符的 alias,会被列为带有 挂载 按钮的 已配置 项,因此无法在它所在的行上卸载。

  • 成功的卸载被记录为错误: 重复卸载、卸载已在别处卸载的内容,或耗时超过 30 秒的卸载——macOS 的 NFS 挂载要等待 Finder 释放该卷——会让该行一直停留在 错误。现在 RcloneView 会检查挂载是否确实已经消失。

  • 挂载管理器丢失了盘符(Windows): 在 挂载到本地路径 模式下,用 浏览 选择的文件夹被保存时没有带上盘符,因此 保存并挂载 失败,且失败的条目仍留在列表中。

  • 文件夹选择器之前出现错误框(Windows): 当挂载点仍为 Auto: 时点击 浏览本地文件夹,会在文件夹选择器之前显示“You can't open this location using this program”。

  • 盘符挂载未出现在本地磁盘标签页中(Windows): 通过向导挂载的盘符会出现在文件资源管理器中,却不出现在 RcloneView 的本地磁盘标签页中,因为该标签页在盘符出现之前就已刷新。现在该标签页会等待盘符出现。

文件浏览器、比较与过滤​

  • 对象名称中的反斜杠(Windows): 在 Windows 主机上,名称中含有反斜杠的云端对象会被当作文件夹分隔符而拆分。

  • 文件名称中的反斜杠(macOS 和 Linux): 路径规范化使名称中含有反斜杠的文件与排除规则脱节。

  • 过滤条件中转义的模式字符: 应用自带的过滤预览无法匹配转义的模式字符,因此您在屏幕上看到的与 rclone 实际所做的并不相同。

  • Dropbox 的隐藏文件仍被复制: 复制目录时,针对 Dropbox 隐藏文件的排除规则没有生效。

  • 浏览器中缺少本地驱动器(Windows): 本地驱动器没有出现在浏览器中。

  • 使用比较之后出现错误: 修复了在比较之后运行操作时频繁出现的错误。

  • “打开”总是使用左侧面板: 远程管理器中的 打开 无论您正在哪个面板中操作,都会把远程放进左侧面板,替换掉您正在对照的视图。现在它会在当前活动的面板中打开。

  • rclone 重启时文件浏览器标签页被关闭: 当内嵌的 rclone 在另一个端口上恢复运行时——在 重启rclone 之后,或从连接管理器连接之后——或者 更新 Rclone 更改了其版本时,两个面板中的每个远程标签页都会被关闭,并且在重启应用后这些标签页也不会恢复。

启动、应用锁、退出与许可证​

  • Dock 图标绕过了应用锁(macOS): 应用处于锁定状态时点击 Dock 图标,会不要求输入密码就打开窗口。

  • 托盘菜单绕过了应用锁: 当应用被锁定并隐藏在托盘中时,托盘的 挂载 项——挂载或卸载已保存的挂载,以及 全部卸载——无需密码就会运行,设置为在文件管理器中打开的挂载也会打开其文件夹。 当窗口是最小化而不是隐藏时,打开 → 远程会在询问密码之前就添加标签页。现在所有这些操作都会先要求输入密码。

  • 托盘出现两次密码提示(Windows): 在锁定的窗口处于最小化状态时,选择托盘子菜单项,例如 打开 → 远程或 挂载 → 新挂载,会弹出两个密码提示;解锁之后,第二个提示仍停留在应用之上,在那里点击 退出 会退出 RcloneView。

  • 启动时的密钥环密码提示(Linux): 在登录密钥环一直保持锁定的情况下——自动登录、远程桌面、指纹登录——RcloneView 每次启动都会在窗口出现之前要求输入密码。那其实是 GNOME 密钥环在请求解锁,而不是请求管理员权限,并且取消它会让应用卡死。 现在 RcloneView 在 Linux 上不再接触密钥环。

  • 向导出现在锁定屏幕之上: 向导可能会出现在 输入应用锁密码 屏幕之上。

  • 从次要窗口重置应用: 在次要窗口的锁定屏幕上运行 重置应用,会让主窗口继续使用已被清除的设置和数据库运行。

  • “退出应用时停止 rclone”被忽略: 在 macOS 上用 ⌘Q 或关闭窗口退出,以及在锁定屏幕上选择 退出 或 重置应用,都会忽略 退出应用时停止 rclone 设置。

  • 重启 rclone 可能永远卡住: 更改配置后重启 rclone 可能会一直停在无尽的转圈状态,因为停止旧进程的请求没有时间限制。

  • 试用期是否到期只在启动时检查: 试用期是否已到期只在进程启动时判定一次,之后不再重新评估。

  • 升级为付费许可证后的自动挂载: 切换到付费许可证后自动挂载没有运行,因为检查发生在许可证验证完成之前。

  • 许可证注册错误信息: 注册失败时,现在会用您的语言显示原因。没有应答的服务器会被报告为无法连接,并提醒您检查互联网连接、防火墙和代理,而不是报告为意外错误。 对于密钥无效之类的失败,不再出现代理方面的建议,并且复制的诊断信息会写明实际被阻止的请求方法。

创建远程与登录​

  • 缺少服务商专属选项: 属于特定服务商的选项被用错误的名称过滤,因此 Storj 访问凭据、Koofr 端点和若干 Oracle 字段始终没有出现。

  • 必填选项被隐藏在高级选项下: Compress 无法保存,因为其必填的 level 选项被隐藏在高级选项下,Oracle Object Storage 也因 compartment 以同样的方式被阻止。

  • Oracle 认证方式: 从列表中选择 no_auth 或 user_principal_auth 会使服务商配置错误。

  • 保存编辑后的远程可能卡住: 保存对现有远程的更改时,rclone 内部可能停止响应。

  • OneDrive 个人版: 设置个人版远程时可能停在 验证连接,并且底层错误被隐藏,而失败的驱动器查找可能会保存一个空的远程。

  • 等待接受条款的 iCloud 账户: 尚未接受 Apple 更新条款的账户只会失败并显示 no auth method found,无从得知问题出在哪里。现在会显示真正的原因。

  • Google Photos 客户端 ID: 使用您自己的客户端 ID 的要求没有应用在应用实际走的路径上。

向导​

  • 编辑由向导创建的作业: 编辑时源和目标看起来是空的,保存时会用这些空值覆盖真实的值。

  • 远程 rclone 的挂载位置(Windows): 在连接到另一台机器上的 rclone 时,向导把本机上的主目录路径建议为挂载位置。

  • 以本地文件夹作为备份源(Windows): 选择本地文件夹作为源时会出现错误。

  • 通过向导挂载(Windows): 从向导挂载失败的频率远高于应有的水平。

  • 使用相同的远程名称重试: 登录失败后,点击 返回 并用相同的远程名称再次尝试会被拒绝。

  • 用“返回”重命名远程: 创建远程后点击 返回 并以新名称继续,会让旧的远程与新的远程一起列在列表中,直到向导关闭。如果任务已经运行过,这次重命名会删除已保存的挂载、计划作业或 Crypt 远程所指向的那个远程。 现在较早的那个远程会立即被移除,并且仅在向导保存的任何内容都不使用它时才会移除。

  • 向导中的 iCloud Photos: 在使用 浏览 之后添加 iCloud Photos 远程会出现错误。现在 iCloud Photos 只在 浏览 任务中提供;备份、同步、挂载、比较和 Crypt 任务不再列出它。 已经把 iCloud Photos 用作源的作业会继续运行,您仍然可以在 作业管理器 中创建这样的作业。

语言与界面​

  • 未翻译的屏幕: 语言下拉列表本身、两个 Telegram 远程控制字段标签、Web 服务器设置部分,以及 iCloud Photos 的“激活标签页时自动同步”设置,在所有语言中都显示为英文。日语的删除作业确认信息缺少作业名称。

  • 设置中的开关行: 带边框的设置区域内的开关行不显示墨水效果,并触发了调试断言。

  • 终端中的帮助弹窗: 在终端中输入目录名称会被当作命令处理,并弹出帮助弹窗。

  • 版本信息(Windows): 修复了 RcloneView 显示的版本信息。

  • 更改数据库文件夹导致无法保存: 在设置中更改 数据库文件夹 之后,在应用重启之前,所有对作业、挂载和历史记录的保存与查找都会失败。

打包与更新​

  • Linux 上捆绑的 rclone: Linux 安装包是用构建机器上碰巧存在的 rclone 构建的,可能会附带 rclone 1.60.1 的开发版本。现在 Linux 版本捆绑的是与其他平台相同的固定版本 rclone。

  • 更新未能到达现有的 deb/rpm 安装: 已保存的 rclone 路径优先于捆绑的二进制文件,因此更新之后捆绑的 rclone 始终没有生效。

  • “更新 Rclone”总是失败却报告成功(Linux): 在普通用户账户下,就地更新捆绑的 rclone 无法成功,但应用仍然报告成功,因为它是根据终端的退出代码来判断结果的——而且这次尝试还中断了正在进行的传输。

  • “更新 Rclone”拒绝更新您自己拥有的 rclone(Linux): 当 本地 Rclone 位置 指向由您的账户拥有的 rclone 时,更新 Rclone 会显示与捆绑版本相同的“无法写入”提示,并且根本不去尝试,因此在 Linux 上完全无法从应用中更新 rclone。 现在会更新您自己拥有的 rclone;捆绑的那个仍然交由软件包来更新。

  • aarch64 RPM 无法安装: aarch64 rpm 把一个仅限 Rockchip 的库(librockchip_mpp)列为依赖,因此在 Fedora 以及其他不提供该库的发行版上,dnf install 可能会拒绝安装。

  • 构建失败被悄悄忽略: 在 Windows 和 macOS 上,安装程序步骤失败的构建仍可能被当作成功而发布。现在这些脚本会明确地报错失败。